Release: UMD-3.11.0

Description
UMD 3.11.0 is the eleventh update of the third Major release of UMD (Unified Middleware Distribution) made available for the EGI production infrastructure. This release contains support for both Scientific Linux 5 and 6 and also Debian 6 (Squeeze).

Contact Info
For further information about the UMD, its goals and surrounding processes, and
more information about how to engage as a Technology Provider with EGI, please
send an Email to: cto (at) egi.eu.

Technical Contact Info
For any bugs and issues you encounter that are not described in the release
notes of this UMD release, or the related documentation provided by the
Technology Providers, please visit the EGI Helpdesk to make a report.

Release Notes
This release contains the following products:

Accounting

  • APEL, v. 1.3.1, versions for SL5 and SL6:
    • This update fixes some issues and provides new features like:
      • Corrected the handling of multiple FQANs in blah logs so that the role and group are taken from the first (i.e. primary) FQAN rather than the last. This will impact the summarising of job records when there are multiple roles and groups listed.
      • Added support for parsing fractional seconds in XML usage records.
    •  For more details see Extended Changelog
  • APEL SSM, v. 2.1.5, versions for SL5 and SL6:
    • This update fixes some issues like:
      • The highest version of SSL/TLS available is now used (previously only SSL 3.0).
      • Minor tweaks made to logging calls and the logging level of certain messages.
    • For more details see Extended Changelog

Attribute authority

Authentication

  • UNICORE-Gateway v. 7.2.0, versions for SL6 and Deb 6:
    • fix: message charset was always ISO-8859-1, and UFT-8 characters were not properly transmitted (SF bug # 770)
    • initial support for multipart POST messages (but SOAP part must be first) (SF feature #292)
    • More details in the Extended Release Notes & Documentation

Client Tools

  • GFAL2-util, v. 1.1.0, versions for SL5 and SL6:
    • This update fixes some issues and provides new features like:
      • fix for is_alive is not available in Python 2.4 (EL5)
      • support input from file in gfal-copy and gfal-del
      • Create a cli around xattr+replicas to ease its use
    • For more details see Extended Release Notes

Credential management

  • gLite-ProxyRenewal v. 1.3.36, versions for SL5 and SL6:
    • This is a rebuild of ProxyRenewal with the new major version of MyProxy (v. 6). There were updated manual pages. This revision also introduces packaging updates to better follow existing packaging guidelines, and missing runtime dependency on psmisc were added.
    • For more details see PX 1.0.26-1 - Extended Release Notes
Data Acces
  • DAVIX, v. 0.4.0, versions for SL5 and SL6:
    • This update fixes some issues and provides new features like:
      • Davix follows redirection automatically even though redirectionSupport is switched off
      • Davix: POODLE vulnerability CVE-2014-3566 affects libneon, then davix
      • DAVIX : implement a list bucket feature for davix on the opendir/readdir model
    • For more details see Extended Release Notes

File Access, File Transfer, Storage Management

  • DPM/LFC, v. 1.8.9, versions for SL5 and SL6:
    • This update fixes some issues and provides new features like:
      • Extensive Logging Consolidation effort in the core components, the source structure, and the test infrastructure
      • Several high impact performance improvements in the core components In-memory caching of pool/fs info in DMLite adapter
      • Bye bye YAIM, welcome Puppet
    • For more details see Extended Release Notes
  • FTS3, v. 3.2.30, version for SL6:
    • This is the first release in UMD of FTS3 - "the production FTS service for all the LHC experiments"
    • For more details see Extended Release Notes

  • Frontier SQUID, v. 2.7STABLE9-21.1, version for SL5 and SL6:

Information Discovery

  • Globus InfoProviderService, v. 0.2.1, version for SL5 and SL6:
    • For more details see...

Job Execution, Job Scheduling

  • CREAM, v. 1.16.4, versions for SL5 and SL6:
    • This release provides bug fixes:
      • The CREAM service does not depends anymore on VOMS client 2.x
      • Use VOMS/CanL APIs instead of VOMS UI
    • For more details see Extended Release Notes
  • QCG-Computing, v. 3.4.0, versions for SL6:
    • This release provides
      • Updated Java SDK to use JGlobus 2.0.8
      • Created RPM package for application scripts (qcg-appscripts)
      • Bug fixes
    • For more details see Extended Release Notes
  • UNICORE TSI v. 7.2.0, versions for SL6 and Deb 6:
    • fixes
      • newline characters in filenames break listDirectory (SF #769)
      • Slurm: remove extra "\n" when setting account
      • cleanup SSL code, make it more portable with respect to IPv6/IPv4. Use separate key and certificate files.
      • in non-SSL mode, configuring the tsi.njsport is mandatory
    • updated docs on configuring SSL
    • added section on securing/hardening the TSI to the manual
    • More details in the Extended Release Notes & Documentation
  • UNICORE/X v. 7.2.0, versions for SL6 and Deb 6:
    • new features:
      • support Unity with OIDC (SF feature #344)
      • support S3 as backend storage (SF feature #342)
    • fixes:
      • data triggering could miss some files
      • file existence check (to compensate for slow filesystems) did not work (SF bug #762)
      • REST authentication: only first authentication option was used, SAML AuthN was buggy
    • More details in the Extended Release Notes & Documentation

Job Scheduling

  • WMS v. 3.6.6-2, versions for SL5 and SL6:
    • This is a rebuild of WMS-ICE with the new major version of MyProxy (v. 6)
Messaging
  • QCG-Notification, v. 3.4.0, versions for SL6:
    • This release provides
      • Disabled KEEP_ALIVE flag for the anonymous and SSL publishers.
      • Updated requirement for qcg-core to the version 3.4.0.
      • Minor fixes
    • For more details see Extended Release Notes

Other
  • BLAH v. 1.20.7, versions for SL5 and SL6:
    • This release fixes the following bugs:
      • CREAM-155 - BUpdate interval does not work with GE
      • CREAM-152 - Wrong condor_status renaming in postinst
  • CGSI-gSOAP, v. 1.3.7, versions for SL5 and SL6:
    • This update fixes:
      • x509_* data members are leaking
      • CGSI-soap changes to be more verbose and meaningful
    • For more details see Extended Release Notes
  • CREAM TORQUE module, v. 2.1.4, versions for SL5 and SL6:
    • This release provides bug fixes:
      • Missing check in triggerun for lcg-info-dynamic-scheduler-pbs
      • TORQUE provider should publish undefined values
    • For more details see Extended Release Notes

  • CREAM GE modulev. 2.3.2 , versions for SL5 and SL6:
    • This release provides multiple bugfix afecting the info-dynamic-scheduler and also an improved Glue2 support
  • GFAL2, v. 2.7.8, versions for SL5 and SL6:
    • This update fixes some issues and provides new features like:
      • LFC Plugin: Calling gfal2_set_error with wrong parameters
      • Core: Cannot use unix special files as a destination for file transfer
      • Deprecate gfal_handle and gfal_context_t inside gfal2
      • GridFTP Plugin: Log storage IPv6
    • For more details see Extended Release Notes
  • GFAL2-python, v. 1.6.0, versions for SL5 and SL6:
    • This update fixes some issues and provides new features like:
      • Expose gfal_version in the Python wrappers
      • Pythonize names transfer_parameters and gfalt_event
      • Core: New method to load configuration from a file (gfal2_load_opts_from_file)
    • For more details see Extended Release Notes
  • SRM-ifce, v. 1.21.4, versions for SL5 and SL6:
    • This update fixes some issues and provides new features like:
      • srm_xping and xrm_ping bad return codes on error
      • bring online timeout is not set correctly in gfal_srmv2_bring_online_internal
      • Add srm_xping, returning more information that srm_ping
    • For more details see Extended Release Notes
  • classads-libs, v. 1.0.10, versions for SL5:
    • New version in EPEL 5 with new maintainer (Frantisek Dvorak)
  • edg-mkgridmap, v. 4.0.1, versions for SL5 and SL6:
    • No longer require SSLv3, allow TLS to be negotiated instead.
    • Relocation of source repository.
    • Cleanup for EPEL builds.
  • python-lockfile, v. 0.8.3, version for SL5:
    • package retired from EPEL 5 repos but needed as dependency by some middleware components
  • python-reportlab, v. 2.5.3, version for SL5:
    • package retired from EPEL 5 repos but needed as dependency by some middleware components
  • SOAPpy, v. 0.11.6, version for SL5:
    • package retired from EPEL 5 repos but needed as dependency by some middleware components

Additional Details
https://wiki.egi.eu/wiki/UMD-3:UMD-3.11.0

Installation Notes
All products in the UMD 3.11.0 release were verified against EGI's current  Quality Criteria (for further information, please see the documentation links) to support Scientific Linux 5 and Scientific Linux 6 (x86_64 processor architecture). Some products are also supported in 64 bit Debian 6 (squeeze).  Installation and configuration notes are available in the EGI repository.

Known Issues
Details containing known issues and workarounds found in EGI verification and
staged rollout are collected in:
https://wiki.egi.eu/wiki/UMD-3:UMD-3.11.0

Change Log
This releases includes updates for the following products: APEL Clents & SSM, CGSI-gSOAP, CREAM TORQUE module, CREAM GE module, CREAM, DAVIX, DPM, glite-ProxyRenewal, GFAL2, GFAL2-util, GFAL2-python, Globus Toolkit 6.0, FT3, Frontier SQUID, MyProxy, ProxyRenewal, QCG Computing, QCG Notifier, SRM-ifce, VOMS Server, Clients and APIs, WMS, UNICORE 7.2.0 ( X, XUUDB, Gateway, TSI, Registry)

Repository URL
http://repository.egi.eu/sw/production/umd/3

UMD-3.11.0 Products
ProductPlatforms SupportedProvided By
CREAM TORQUE 2.1.4sl5/x86_64, sl6/x86_64EMI
CREAM 1.16.4sl5/x86_64, sl6/x86_64EMI
voms-admin 3.3.1sl5/x86_64, sl6/x86_64EMI
voms-clients 3.0.5sl5/x86_64, sl6/x86_64INFN
squid 2.7.21sl5/x86_64, sl6/x86_64CERNFRONTIER
fts3 3.2.30sl6/x86_64FTS3
dpm 1.8.9sl5/x86_64, sl6/x86_64DPM
voms-clients 3.0.6sl5/x86_64, sl6/x86_64INFN
classads-libs 1.0.10sl5/x86_64, sl6/x86_64EMI
dmlite 0.7.2sl5/x86_64, sl6/x86_64DPM
gfal2-utils 1.1.0sl5/x86_64, sl6/x86_64EPEL
gfal2-python 1.6.0sl5/x86_64, sl6/x86_64EPEL
srm-ifce 1.21.4sl5/x86_64, sl6/x86_64EPEL
CGSI-gSOAP 1.3.7sl5/x86_64, sl6/x86_64EPEL
davix 0.4.0sl5/x86_64, sl6/x86_64EPEL
Gfal2 2.7.8sl5/x86_64, sl6/x86_64GFAL2
Globus Info Provider Service 0.2.1sl5/x86_64, sl6/x86_64IGE
wms-ice 3.5.4sl5/x86_64, sl6/x86_64EMI
px 1.3.36sl5/x86_64, sl6/x86_64CESNET
globus-default-security 6.0.0sl5/x86_64, sl6/x86_64GLOBUS
gridFTP 6.0.0sl5/x86_64, sl6/x86_64GLOBUS
qcg-ntf 3.4.0sl6/x86_64QCG
qcg-comp 3.4.0sl6/x86_64QCG
myproxy 6.1.10sl5/x86_64, sl6/x86_64GLOBUS
apel 1.3.1sl5/x86_64, sl6/x86_64APEL
apel-ssm 2.1.5sl5/x86_64, sl6/x86_64APEL
edg-mkgrid 4.0.1sl5/x86_64, sl6/x86_64EMI
python-lockfile 0.8.5sl5/x86_64EMI
Gram5 6.0.1sl5/x86_64, sl6/x86_64GLOBUS
SOAPpy 0.11.6sl5/x86_64EMI
tsi 7.2.0debian6/amd64, sl6/x86_64UNICORE
registry 7.2.0debian6/amd64, sl6/x86_64UNICORE
cream-ge 2.3.1sl5/x86_64, sl6/x86_64EMI
gateway 7.2.0debian6/amd64, sl6/x86_64UNICORE
x 7.2.0debian6/amd64, sl6/x86_64UNICORE
xuudb 7.2.0debian6/amd64, sl6/x86_64UNICORE
python-reportlab 2.5.3sl5/x86_64EMI

This entry was posted in UMD-3. Bookmark the permalink.